Setup.exe Problems on Vista

Michael D. Adams
Mon Apr 23 23:19:00 GMT 2007

On 4/22/07, Brian Dessent <> wrote:
> Brian Dessent wrote:
> > > The workaround for this problem that I have found is to set the
> > > *Windows* path to include C:\cygwin\bin before running setup.exe.  So
> > > for example this sequence works:
> > >
> > > set PATH=C:\cygwin\bin;%PATH%
> > > setup.exe
> > >
> > > Then /bin/sh is actually created, the prompt is the usual Cygwin settings, etc.
> > > Of course the proper solution would be to find and fix the root cause.
> > >  Is this a known bug?  Is there any other info I can provide to help
> > > find the root cause? (I'm suspicious that Vista might not allow the
> > > program to set PATH.)
> >
> > That would be pretty brain dead if Vista did not allow programs to
> > modify the PATH.  That would cause about a million failures in Cygwin
> > and various programs.
> >
> > > OS: Vista Home Premium
> > > Setup.exe Version: 2.510.2.2 (run without administraitor permission)
> >
> > Please try the latest setup.exe snapshot, if you can.  And even better
> > would be to debug the problem.  I don't have access to a Vista system
> > but if I did I think I would start by running it under gdb/insight and
> > putting a breakpoint at right before CreateProcess and
> > check the environment.  Or create a test package with a postinstall that
> > just runs "env > /tmp/foo" or "sleep 1h" or something so that you can
> > inspect the environment.
> Just now I installed Vista under VMware to try installing Cygwin.  It
> worked fine using the latest version of setup.exe.  I did not have to
> disable UAC but it did prompt me to run as Administrator (which it does
> for any executable named setup.exe IIRC.)  Postinstall scripts all ran
> fine, sh.exe was there and there was no need to put \cygwin\bin in the
> PATH manually.

I tried a fresh install of cygwin (after stashing away the old version
(with move, but I skipped the unmoust since I use the default mounts
anyway)) with setup.exe version 2.562 (from the snapshots).  Oddly,
while sh.exe is now being created and the prompt is the colored one
that Cygwin usually sets, /etc/passwd is not being created.  I am
uncertain whether this is the same bug manifested in a new way or if
it might be a new bug.  (Obligatory grumble about Vista being a pain.)

Did you check your /etc/passwd?  I only noticed it b/c when I started
the shell my home directory was set to C:\Users\<my_user> instead of
C:\cygwin\home\<my_user>.  (C:\Users is Vista's version of what in XP
is C:\Documents and Settings.)

Michael D. Adams

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list