Setup.exe Problems on Vista

Dave Korn
Mon Apr 23 23:27:00 GMT 2007

On 24 April 2007 00:19, Michael D. Adams wrote:

> On 4/22/07, Brian Dessent <brian@dessent.OOOPS!> wrote:

  Please, Michael, try and avoid
quoting people's email addresses.  Thanks.

>>>> The workaround for this problem that I have found is to set the
>>>> *Windows* path to include C:\cygwin\bin before running setup.exe.  So
>>>> for example this sequence works:
>>>> set PATH=C:\cygwin\bin;%PATH%
>>>> setup.exe

>> Just now I installed Vista under VMware to try installing Cygwin.  It
>> worked fine using the latest version of setup.exe.  I did not have to
>> disable UAC but it did prompt me to run as Administrator (which it does
>> for any executable named setup.exe IIRC.)  Postinstall scripts all ran
>> fine, sh.exe was there and there was no need to put \cygwin\bin in the
>> PATH manually.
> I tried a fresh install of cygwin (after stashing away the old version
> (with move, but I skipped the unmoust since I use the default mounts
> anyway)) with setup.exe version 2.562 (from the snapshots).  Oddly,
> while sh.exe is now being created and the prompt is the colored one
> that Cygwin usually sets, /etc/passwd is not being created.  I am
> uncertain whether this is the same bug manifested in a new way or if
> it might be a new bug.  (Obligatory grumble about Vista being a pain.)
> Did you check your /etc/passwd?  I only noticed it b/c when I started
> the shell my home directory was set to C:\Users\<my_user> instead of
> C:\cygwin\home\<my_user>.  (C:\Users is Vista's version of what in XP
> is C:\Documents and Settings.)

  What's going on here could be related to security changes in the way Vista
handles dll and executable search paths, perhaps, but that's fairly

  Which reminds me.  Isn't it about time this conversation had some input from
cygcheck on the various systems involved?

Can't think of a witty .sigline today....

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list