RSync random failures

Allan Schrum
Mon Dec 1 02:26:00 GMT 2008

>In the event log the following message was found:

>rsyncd: PID 1800: rsync error: error in file IO (code 11) at /home/lapo/packaging/rsync-3.0.4-1/src/rsync-3.0.4/clientserver.c(985) [receiver=3.0.4].

I downloaded the source, rebuilt and I am running under the debugger. The line indicated above is where RSync discovers that the PID file already exists. While that specific problem is solved by deleting the PID file, the problem is that the PID file should never exist after RSync exits.

There is some condition that leaves the PID file when RSync shuts down (as a service under Windows XP) normally. This problem did not exist in the previous version (2.6.9-2).

I have tried hibernation, stand-by, shutdown & restart, network disconnections, various signals passed, etc., and nothing reliably causes the problem to manifest itself. But any of these methods has caused the problem. It seems to happen more frequently during shutdown & restart than any other method.

Any ideas on how to debug? Anyone else have this problem?




Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list