NT-Authority/System will be file owner after rsync restore

Matthias Meyer Matthias.Meyer@gmx.li
Tue Dec 2 21:18:00 GMT 2008

Larry Hall (Cygwin) wrote:

> Matthias Meyer wrote:
>> create a new file /etc/test.txt
>> bin>ls -alh /etc/test.txt
>> bin>-rwx------+ 1 meyer Kein 0 Dec  1 23:01 /etc/test.txt
>> Than I run a backup:
>> After that my backup-protocol shows:
>>   create   644    18/544           0 etc/Test.txt
>> But 18/544 is SYSTEM:Administratoren
>> as /etc/passwd -> SYSTEM:*:18:544:,S-1-5-18::
>> and /etc/group -> Administratoren:S-1-5-32-544:544:
>> shows.
>> I've tried this with both, "cygrunsrv -I backup ..." as well as
>> with "cygrunsrv -I backup -e CYGWIN=nontsec ..."
>> Any further hint?
> Well services on <= XP run under the local system account so I'm
> guessing that your backup service is using the permissions of the
> creator of the backup files rather than the original permissions.
> 'rsync', according to the man page, says that it has '-p' and
> '-A' flags to preserve the original permission IDs (or '-a' which
> includes '-p').  Are you using any of these?
--archive == -rlptgoD
(--recursive, --links, --perms, --times, --group, --owner, -D)
I use all of them in both, by backup as well as by restore.

Don't panic

Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/

More information about the Cygwin mailing list