Finally managed to create a jailed SFTP server, but how secure?

Fri Dec 5 22:13:00 GMT 2008

> I believe it is still supported for Cygwin 1.5. I think what has
> happened is the Cygwin DLL created an actual /cygdrive directory (which
> is useful for things like bash completion) in your chroot jail. Now that
> you've changed the Cygdrive prefix, delete that directory and all should
> be good.
> BTW, it is preferable to change the Cygdrive prefix with 'mount -c
> ' rather than mess around in the registry.

Many thanks. I tried it and it worked. I could see in the Console that it has 
changed to/drive (instead of /cygdrive). 

  # mount
  C:\cygwin\bin on /usr/bin type system (binmode)
  C:\cygwin\lib on /usr/lib type system (binmode)
  C:\cygwin on / type system (binmode)
  c: on /drive/c type system (binmode,noumount)

And I could cd to /drive/c from Console too.

But when I tried to restart sshd, I got this message:

  # net start sshd
  bash: /cygdrive/c/WINDOWS/system32/net: No such file or directory

Do I need to change somewhere else too?


Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list