Install error on Perl PROC::Background under Cygwin

Ian Puleston
Thu Dec 11 20:59:00 GMT 2008

> -----Original Message-----
> From: Ian Puleston
> I have perl 5.10.0 installed in cygwin, and I'm getting an error trying
> to install the Proc::Background module for it. "ERROR: Can't create
> '/usr/bin'; Do not have write permissions on '/usr/bin'"

That perl module uses the ExtUtils::Install module to install itself, so I
tried upgrading that to the latest and got a similar error trying to install
that one:

ERROR: Can't create '/usr/lib/perl5/5.10/ExtUtils'
Do not have write permissions on '/usr/lib/perl5/5.10/ExtUtils'

But then examining write permissions on that file led me to the cause. This
PC is logged into a Windows domain and in Cygwin my group is "Domain Users",
but for some reason the Cygwin installation directories had all been created
with group "Users" and with no write permission on directories including
/usr/bin. The following two commands, which needed to be run from an
elevated bash window, fixed it and allowed the perl module to install

[~]: chgrp -R "Domain Users" /cygdrive/c/Cygwin/    
[~]: chmod +w /usr/bin/


Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list