bash can't fork cvs, but gdb and ash can

Eliot Moss
Thu Dec 11 22:03:00 GMT 2008

Dear cygwin maintainers -- While I saw a lot of things around the web
concerning rebase, not being able to fork, etc., I was not able to get
to the bottom of this problem or work around it. The details:

 From bash, I cannot run cvs. It fails to fork after giving my a number
of popups asking if I want to report the problem to Microsoft. The
popups is offered when execution is at offset 4716 in cygwin1.dll.
This happens with the recent versions of cvs available through setup.exe,
and also if I build and install cvs from scratch. Other programs seem
to work, so I'm thinking maybe it has something to do with a library
or dll that cvs uses but other things that I usually run do not use.

If I run cvs under gdb or ash, it goes fine. The problem appears to be
in the forking, not in the running itself.

I've tried uninstalling and reinstalling cygwin, cvs, etc., multiple
times with no joy. If rebase is needed, i am not sure what needs rebasing.

I attach the cygcheck output you request with such reports.

This problem started just today, though I have not run cvs much in the
last month. Obviously I have done some recent cygwin updates. Also, there
have been some of those monthly Microsoft updates.

Thanks for nay help you can offer -- Eliot Moss, Computer Science, UMass
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: cygcheck.out
URL: <>
-------------- next part --------------
Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list