Cygwin 1.7 domains and home directories

Corinna Vinschen
Tue Dec 16 16:06:00 GMT 2008

On Dec 16 12:25, John Morrison wrote:
> On Tue, December 16, 2008 12:09 pm, Corinna Vinschen wrote:
> > So far I'm not able to reproduce this.  Every time I reboot, the shell
> > comes up just fine.
> >
> > For testing purposes I created an /etc/group file of >28000 entries.
> > I also switched my home directory by adding a fstab entry along the lines
> > of "D:/home/corinna --> /home/corinna", but to no avail.
> >
> > I tested this on a Vista machine which is domain member of a 2K8 domain
> > with a domain admin account with UAC enabled.
> >
> > I'll try later again on an XP machine.
> XP sp2

No go either.  I rebooted multiple times and every time it was fine

> > Is your account an admin account or a normal user account?  I don't
> > know but maybe that makes some difference.
> I have local admin rights (ie, only on this machine), but it's a domain
> account (hope that makes sense).

It does.  I tried with an admin account which is also Domain Admin and I
tried with a non-admin account which is just member of Domain Users and
some other plain group.

> > Maybe that goes without saying, but somebody actually debugging this
> > who can reproduce this behaviour would be a great help...
> I've altered the cygwin.bat file changing
> bash --login -i
> to
> strace -o c:\strace.txt bash --login -i
> but I've yet to reproduce it since I made the modification :(  (and even
> if it did, I wouldn't know what to look for in the 11MB+ trace!)

You don't have to.  If it occurs under strace, I can take a look.  Maybe
we have to add additional debug output, though.


Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Project Co-Leader          cygwin AT cygwin DOT com
Red Hat

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list