Cygwin 1.7 domains and home directories

Christopher Faylor cgf-use-the-mailinglist-please@cygwin.com
Tue Dec 16 18:11:00 GMT 2008


On Tue, Dec 16, 2008 at 06:06:06PM -0000, John Morrison wrote:
>On Tue, December 16, 2008 4:06 pm, Corinna Vinschen wrote:
>> On Dec 16 12:25, John Morrison wrote:
>>> On Tue, December 16, 2008 12:09 pm, Corinna Vinschen wrote:
>>> > So far I'm not able to reproduce this.  Every time I reboot, the shell
>>> > comes up just fine.
>>> >
>>> > For testing purposes I created an /etc/group file of >28000 entries.
>>> > I also switched my home directory by adding a fstab entry along the
>>> lines
>>> > of "D:/home/corinna --> /home/corinna", but to no avail.
>>> >
>>> > I tested this on a Vista machine which is domain member of a 2K8
>>> domain
>>> > with a domain admin account with UAC enabled.
>>> >
>>> > I'll try later again on an XP machine.
>>>
>>> XP sp2
>>
>> No go either.  I rebooted multiple times and every time it was fine
>> passwd/group-wise.
>>
>>> > Is your account an admin account or a normal user account?  I don't
>>> > know but maybe that makes some difference.
>>>
>>> I have local admin rights (ie, only on this machine), but it's a domain
>>> account (hope that makes sense).
>>
>> It does.  I tried with an admin account which is also Domain Admin and I
>> tried with a non-admin account which is just member of Domain Users and
>> some other plain group.
>>
>>> > Maybe that goes without saying, but somebody actually debugging this
>>> > who can reproduce this behaviour would be a great help...
>>>
>>> I've altered the cygwin.bat file changing
>>>
>>> bash --login -i
>>>
>>> to
>>>
>>> strace -o c:\strace.txt bash --login -i
>>>
>>> but I've yet to reproduce it since I made the modification :(  (and even
>>> if it did, I wouldn't know what to look for in the 11MB+ trace!)
>>
>> You don't have to.  If it occurs under strace, I can take a look.  Maybe
>> we have to add additional debug output, though.
>
>I'll keep trying it, but I've only seen it at work and I can't keep
>rebooting!  I've got to do *some* work ;)
>
>I'm *sure* I've seen it without having to reboot.  Are you planning
>another release of the dll soon(ish)?  Does cygwin do anything if/when it
>detects that the dll has changed?  I've tried 'touch'ing it, that didn't
>trigger anything.

If you want to update just the DLL you could always try a snapshot:

http://cygwin.com/snapshots/

cgf

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list