[1.7] Pipes intermittently lose data on Cygwin 1.7

Lawrence Mayer lawmay3@i12.com
Mon Dec 22 20:07:00 GMT 2008

>> Not yet. The bug is still present in the current snapshot
>> cygwin-inst-20081220.tar.bz2. Thanks for trying to fix it and for
>> responding to my post.

On 081222 10:47, Christopher Faylor wrote:
> Too bad.  Since I can't duplicate the problem it will be difficult to
> fix it.

Have you tried running the examples I provided in my original post (with 
foo = ~ 5MB text file) on a DOS shell (cmd.exe)?

I suggest running each example (in a DOS shell) at least 10 times, 
comparing the file sizes of foo and bar each time. On my system, size of 
bar < size of foo roughly 25-75% of the time.

> It would be helpful if you provided more information like the cygcheck
> information requested in http://cygwin.com/problems.html.

Please see attached the output cygcheck -s -v -r > cygcheck.out. I ran 
cygcheck on the current snapshot cygwin-inst-20081220.tar.bz2.

It would also
> be interesting to see the actual file sizes of foo and bar from your
> example.  If they always vary in a consistent way that would be a clue.

File sizes from latest test I ran (Example 1 of my original post)

	tr \32 \0 < foo | tr \0 \32 > bar

on current snapshot cygwin-inst-20081220.tar.bz:

	foo = 5,138,895 bytes
	bar1 (runs 1-4, 6-7, 9-10) = 5,132,288 bytes
	bar2 (runs 5 and 8) = 5,136,384 bytes

As you can see, there is some consistency. When I ran the above test 10 
consecutive times, there were only two types of output. On 8/10 runs, 
bar was missing the same 6,607 (5,138,895 - 5,132,288) byte chunk. On 
the remaining 2/10 runs, bar was missing the same 2,511 byte chunk.

As mentioned in my original post, the missing chunk is always at the end 
(or beginning in the tac example) of bar. It's as if the pipe exits too 
early, before all the data can make it through.

I'm attaching foo, bar1, and bar2 from the above example (compressed 
with 7zip).


-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: cygcheck.out
URL: <http://cygwin.com/pipermail/cygwin/attachments/20081222/58d86f81/attachment.ksh>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: foobar.7z
Type: application/octet-stream
Size: 103406 bytes
Desc: not available
URL: <http://cygwin.com/pipermail/cygwin/attachments/20081222/58d86f81/attachment.obj>
-------------- next part --------------
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/

More information about the Cygwin mailing list