[1.7] Pipes intermittently lose data on Cygwin 1.7

Lawrence Mayer lawmay3@i12.com
Tue Dec 23 00:28:00 GMT 2008

>>> Too bad.  Since I can't duplicate the problem it will be difficult to
>>> fix it.

>> Have you tried running the examples I provided in my original post
>> (with foo = ~ 5MB text file) on a DOS shell (cmd.exe)?

> Yes.  That's what I meant by "I can't duplicate the problem".

Just ran current snapshot cygwin-inst-20081220 on a different computer 
running a different OS: Windows XP Home sp2 32 bit on NTFS. See attached 
output from cygcheck. Both this and the previous computer have Athlon 

Running a DOS window (cmd.exe) with Example 1 of my original post

     tr \32 \0 < foo | tr \0 \32 > bar

using the same input file foo attached to my previous post gives:

     foo = 5,138,895 bytes
     bar = 5,132,288 bytes

I ran the test twice and got identical output. Moreover, (output) bar on 
this computer was identical to (output) bar1 (attached to my previous 
post) obtained on the other computer (running Windows Server 2003 sp2 32 
bit on NTFS.) With identical output I mean binary identical, not just 
identical file size.

Thus, there is some consistency to this bug even between different 
computers running different versions of Windows. Not complete 
consistency though, as noted in my previous post: sometimes output was 
bar2 not bar1. And on some runs the bug doesn't appear at all, and 
output size = input size.

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: cygcheck.out
URL: <http://cygwin.com/pipermail/cygwin/attachments/20081223/3a378d1f/attachment.ksh>
-------------- next part --------------
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/

More information about the Cygwin mailing list