System reboot (udfs.sys), cygwin 1.7

Gregory C. Sharp
Tue Dec 30 16:27:00 GMT 2008

I'm testing out cygwin 1.7, and ran into a problem.  I run a small
script which checksums my dvd+r backups, something like this:

find -L /cygdrive/d -noleaf -type f -exec cksum {} \;

I try it out on cygwin 1.7, and 3 out of 4 times I get a system
panic and reboot.  Dumpchk/WinDBG reveal access violation in udfs.sys.
This has never happened when I run the script on cygwin 1.5.
Stacktrace as follows:

ChildEBP RetAddr  Args to Child
f683fd78 804eeb49 88768288 00000000 00000000 udfs!0xbb7db225
f683fda8 8052e8c2 88768288 00000000 00000000 ntkrnlmp!ExQueueWorkItem+0x167
f683fddc 80543966 804eea9a 00000000 00000000 
00000000 00000000 00000000 00000000 00000000 

System details: Windows 2000 SP4 fully patched, Pentium IV CPU
(hyperthreaded), UDFS.SYS 5.0.2195.7006 (Dec 2, 2004), Samsung
DVD ROM SD-616T, DVD+R media, Japanese locale (CP932).

Any ideas what is going on?

Gregory C. Sharp
Dept. of Radiation Oncology
Massachusetts General Hospital  /  617-724-3866

The information in this e-mail is intended only for the person to whom it is
addressed. If you believe this e-mail was sent to you in error and the e-mail
contains patient information, please contact the Partners Compliance HelpLine at . If the e-mail was sent to you in error
but does not contain patient information, please contact the sender and properly
dispose of the e-mail.

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list