[1.7] System reboot (udfs.sys), cygwin 1.7

Christopher Faylor cgf-use-the-mailinglist-please@cygwin.com
Tue Dec 30 17:42:00 GMT 2008

On Tue, Dec 30, 2008 at 12:06:38PM -0500, Christopher Faylor wrote:
>On Tue, Dec 30, 2008 at 11:25:43AM -0500, Gregory C. Sharp wrote:
>>I'm testing out cygwin 1.7, and ran into a problem.  I run a small
>>script which checksums my dvd+r backups, something like this:
>>find -L /cygdrive/d -noleaf -type f -exec cksum {} \;
>>I try it out on cygwin 1.7, and 3 out of 4 times I get a system panic
>>and reboot.  Dumpchk/WinDBG reveal access violation in udfs.sys.  This
>>has never happened when I run the script on cygwin 1.5.  Stacktrace as
>>ChildEBP RetAddr Args to Child f683fd78 804eeb49 88768288 00000000
>>00000000 udfs!0xbb7db225 f683fda8 8052e8c2 88768288 00000000 00000000
>>ntkrnlmp!ExQueueWorkItem+0x167 f683fddc 80543966 804eea9a 00000000
>>00000000 ntkrnlmp!PsSetCreateThreadNotifyRoutine+0xa8 00000000 00000000
>>00000000 00000000 00000000 ntkrnlmp!KiDispatchInterrupt+0x516
>>System details: Windows 2000 SP4 fully patched, Pentium IV CPU
>>(hyperthreaded), UDFS.SYS 5.0.2195.7006 (Dec 2, 2004), Samsung DVD ROM
>>SD-616T, DVD+R media, Japanese locale (CP932).
>>Any ideas what is going on?
>We need the information here:
>Also, if you can get an strace of the failure that would probably be
>helpful.  It may be too big to send to the list, though.  If so, please
>let me know here and I'll arrange for a place for you to upload it.

I got a system reboot (once) from this too.  How wonderful is that?

It seemed to die following a symlink in my dev directory.  Investigating


Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/

More information about the Cygwin mailing list