Mouting network drives from Cygwin ssh client

Jeenu V
Wed Dec 31 05:32:00 GMT 2008

Thanks for the link.

I removed the default CYGWIN sshd service and ran:

cygrunsrv --install sshd --path /usr/sbin/sshd.exe --user jeevis01
--args '-D' --env 'CYGWIN="ntsec"

It asked for my password and installed successfully. However I
couldn't start the service, and my /var/log/sshd.log was empty.

Later I tried starting sshd manually:
$ /usr/sbin/sshd.exe
/var/empty must be owned by root and not group or world-writable.

$ ls -ld /var/empty/
drwxr-xr-x+ 2 SYSTEM Administrators 0 Dec 30 16:57 /var/empty/

$ chmod 700 /var/empty/
$ ls -ld /var/empty/
drwx------+ 2 SYSTEM Administrators 0 Dec 30 16:57 /var/empty/

$ /usr/sbin/sshd.exe
/var/empty must be owned by root and not group or world-writable.

I think this is the reason why the server failed to start when I
installed service in my name. Although I see many posts facing similar
issues, problem gets solved after the chmod command. However, for me,
it doesn't. Please help.

PS: Though I've subscribed to the list, replies to this topic is not
reaching my inbox for some reason. I'm reading replies at the archive.

On Tue, Dec 30, 2008 at 9:11 PM, Jeenu V <> wrote:
> Hi,
> I've a Cygwin ssh server up on Windows XP. My home directory on the
> host is a network drive (H:) which I'm able to acess locally as
> /cygdrive/h. When I do ssh to localhost using PuTTY, I'm unable to
> access the /cygdrive/h path - the mount command only shows c: mounted
> as /cygdrive/c. I can neither create directory h inside /cygdrive nor
> mount h: to there - it says no such file or directory. Also there are
> error messages when I log-in because of /cygdrive/h being
> inaccessible, because it's the home directory. Please tell me how to
> access this network drive via. ssh.
> --
> Thanks
> Jeenu


Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list