OPENSSH passwordless login getting "system error 59" on "net use" cmd with samba

Terry Orechia
Fri Feb 1 18:06:00 GMT 2008


I was able to resolve this issue by switching the user who runs the sshd 
service.  If anyone else is having this problem you can find detailed 
documentation on how to do get around this issue this at


----- Original Message ----- 
From: "Terry Orechia" <>
To: <>
Sent: Thursday, January 31, 2008 3:04 PM
Subject: OPENSSH passwordless login getting "system error 59" on "net use" 
cmd with samba

> Hi,
>   I am getting "system error 59" when I run "net use z:\\\\server\\share 
> /user:user1 <password>" to access a samb shared drive in an openssh 
> windows session where I use passwordless login with command "ssh -i 
> <identity_file> user1@<server> " to login to the windows desktop running 
> sshd.  I have been searching the mailing lists, but have not found any 
> information on this specific issue.
>   I am trying to run a batch script from a unix server to execute some 
> commands on the windows desktop that need to access a shared drive.  I 
> installed and configured samba3 on the unix server where the shared files 
> are located.  I have installed and configured the most recent download of 
> cygwin with the openssh option on the windows desktop.  Logged in as user1 
> on the windows destktop, I can run the dos console or the cygwin shell and 
> successfully map network drives usin the "net use" command above.   I am 
> also successfully able to run the "net use" command on the windows client 
> when I login using openssh as user1 and get prompted for the password 
> (using command "ssh user1@<server>").  Therefore I know that I have 
> correctly setup samba, cygwin and openssh for user1 to access the shared 
> drive.  I then created keys using ssh-keygen for passwordless login for 
> user1 on the desktop.   When I login to the desktop using openssh 
> passwordless login for user1 with command "ssh -i <identity_file> 
> user1@server",  I get "system error 59" when I run the same "net use" 
> command above.  I cannot have any user prompts for the passwords in my 
> script.  Does anyone know if is possible to use passwordless login from 
> openssh and then map a network drive using samba to access the shared 
> drive in the ssh session?    If so, any ideas on why this is not working. 
> If this will not work, does anyone know if this will work with SFU ( in 
> place of samba) or any other software for sharing the drives?
> Thanks for you help in this issue,
> Terry

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list