GCJ support for Java 1.5

René Berber r.berber@computer.org
Thu Feb 7 00:04:00 GMT 2008


Solly Ezekiel wrote:

> I have a question I haven't seen addressed in the FAQ and mailing
> lists.  Specifically, are there plans for gcj under Cygwin to support
> Java 1.5 features such as generics?
> 
> The gcj web page (http://www.gnu.org/software/gcc/java/) says Java
> 1.5 language support is available as of gcc v4.3, but Cygwin is up to
> only v3.4 of gcc.
[snip]

As you already know, the answer is no, not with the gcc version 
currently distributed with Cygwin.

There are 2 available options, the first is free, the second is not 
(includes SWT and other stuff), both are MingW versions of gcc 4.3 :

   http://www.thisiscool.com/gcc_mingw.htm

   http://jnc.mtsystems.ch/

Hope this is useful.
-- 
René Berber


--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list