Updated: clisp-2.44-1 for cygwin

Reini Urban rurban@x-ray.at
Thu Feb 7 08:43:00 GMT 2008


Eric Blake schrieb:
> According to Larry Hall (Cygwin) on 2/5/2008 8:42 PM:
> |>      $ /usr/bin/clisp -norc -q -K full || echo $?
> |>      53
> |> No such error is returned for the base set of modules for either version
> |> 2.43-2 or 2.44-1:
> |>
> |>      $ /usr/bin/clisp -q -norc -K base || echo $?
> |>      [1]>_
> |>
> | Sounds like it could be a missing dependency problem.  Does 'cygcheck
> | clisp' report any missing DLLs?
> 
> Yep.  Looking at the strace, -K full triggers the exec of
> /lib/clisp-2.44/full/lisp.exe, which complains:
> $ cygcheck /lib/clisp-2.44/full/lisp
> c:\cygwin\lib/clisp-2.44/full/lisp.exe
> ...
> Error: could not find cygpq5.dll
> 
> Yet:
> $ cygcheck -p cygpq5
> Found 0 matches for cygpq5.
> 
> So, what is cygpq5.dll, and has it ever been in the distribution?  At any
> rate, it looks like clisp needs to be rebuilt to either provide this dll
> or not link against it.

Oh my! Sorry for that.

I have explictly -lpq in my clisp full linker line, but my new 
postgresql-8.2 forward library /lib/libpq.a loads cygpq5.dll,
not cygpq.dll.

So I'll upload a new clisp-2.44-2 and fix my internal test packages for 
postgresql 8.2 and the new 8.3 to use the old name and do the dll 
versioning optional.
8.3 will be the new test postgresql package soon.
-- 
Reini Urban

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list