[1.5.25-7] bash: fork Permission denied

Jamil Ben Alluch mlr@autronix.com
Sun Feb 17 04:42:00 GMT 2008

I have been trying to install cygwin for the last couple of days with no 
I have installed the very basic stuff (Base + whatever else is required 
for a working installation).
Once setup finishes I launch Cygwin; this is the output I get:

Copying skeleton files.
These files are for the user to personalise
their cygwin experience.

These will never be overwritten.

     10 [main] bash 672 fork: child -1 - CreateProcessA failed, errno 13
bash: fork: Permission denied
bash-3.2$ ./.bash_profile
bash-3.2$ ./.inputrc
./.inputrc: line 17: \e[3~:: command not found
./.inputrc: line 20: \e[1~:: command not found
./.inputrc: line 21: \e[4~:: command not found
./.inputrc: line 24: \e[H:: command not found
./.inputrc: line 25: \e[F:: command not found
./.inputrc: line 28: \e[7~:: command not found
./.inputrc: line 29: \e[8~:: command not found
./.inputrc: line 32: \eOH:: command not found
./.inputrc: line 33: \eOF:: command not found
bash-3.2$ exit
     10 [main] bash 4212 fork: child -1 - CreateProcessA failed, errno 13
bash: fork: Permission denied

I've tried to install in other directories with no success.
I had a working installation of cygwin before and tried reinstalling it 
after it stopped working for a reason that is still unknown to me (I 
suspect windows update, but I'm not sure...)

Any help appreciated.



Here is my cygcheck output:


Cygwin Configuration Diagnostics
Current System Time: Sat Feb 16 19:29:57 2008

Windows XP Professional Ver 5.1 Build 2600 Service Pack 2

Path:    C:\WINDOWS\system32
    C:\Program Files\ATI Technologies\ATI.ACE\Core-Static
    C:\Program Files\Common Files\GTK\2.0\bin
    C:\Program Files\QuickTime\QTSystem\
    C:\Program Files\SSH Communications Security\SSH Secure Shell
    C:\Program Files\OpenVPN\bin
    C:\Program Files\MKVtoolnix

Output from C:\Cygwin-Linux\bin\id.exe (nontsec)
UID: 1003(Akuma)    GID: 513(None)
0(root)             513(None)           544(Administrators) 545(Users)

Output from C:\Cygwin-Linux\bin\id.exe (ntsec)
UID: 1003(Akuma)    GID: 513(None)
0(root)             513(None)           544(Administrators) 545(Users)

SysDir: C:\WINDOWS\system32

LD_LIBRARY_PATH = '/usr/lib:/usr/X11R6/lib'
Path = 
Files\ATI Technologies\ATI.ACE\Core-Static;C:\Program Files\Common 
Files\QuickTime\QTSystem\;C:\SFU\common\;C:\Program Files\SSH 
Communications Security\SSH Secure Shell;C:\Program 
Files\OpenVPN\bin;C:\Program Files\MKVtoolnix'

ALLUSERSPROFILE = 'C:\Documents and Settings\All Users'
APPDATA = 'C:\Documents and Settings\Akuma\Application Data'
CLASSPATH = '.;C:\Program Files\Java\jre1.6.0_03\lib\ext\QTJava.zip'
CLIENTNAME = 'Console'
CommonProgramFiles = 'C:\Program Files\Common Files'
ComSpec = 'C:\WINDOWS\system32\cmd.exe'
DISPLAY = 'localhost:0.0'
EDITOR = 'vi'
HOMEPATH = '\Documents and Settings\Akuma'
INTERIX_ROOT = '/dev/fs/C/SFU/'
OPENNT_ROOT = '/dev/fs/C/SFU/'
OS = 'Windows_NT'
PROCESSOR_IDENTIFIER = 'x86 Family 6 Model 8 Stepping 1, AuthenticAMD'
ProgramFiles = 'C:\Program Files'
QTJAVA = 'C:\Program Files\Java\jre1.6.0_03\lib\ext\QTJava.zip'
SystemDrive = 'C:'
SystemRoot = 'C:\WINDOWS'
TEMP = 'C:\DOCUME~1\Akuma\LOCALS~1\Temp'
TMP = 'C:\DOCUME~1\Akuma\LOCALS~1\Temp'
USERNAME = 'Akuma'
USERPROFILE = 'C:\Documents and Settings\Akuma'
windir = 'C:\WINDOWS'
XAPPLRESDIR = '/usr/X11R6/lib/X11/app-defaults'
XCMSDB = '/usr/X11R6/lib/X11/Xcms.txt'
XKEYSYMDB = '/usr/X11R6/lib/X11/XKeysymDB'
XNLSPATH = '/usr/X11R6/lib/X11/locale'

HKEY_CURRENT_USER\Software\Cygnus Solutions
HKEY_CURRENT_USER\Software\Cygnus Solutions\Cygwin
HKEY_CURRENT_USER\Software\Cygnus Solutions\Cygwin\mounts v2
HKEY_CURRENT_USER\Software\Cygnus Solutions\Cygwin\Program Options
HKEY_LOCAL_MACHINE\SOFTWARE\Cygnus Solutions\Cygwin\mounts v2
  (default) = '/cygdrive'
  cygdrive flags = 0x00000022
HKEY_LOCAL_MACHINE\SOFTWARE\Cygnus Solutions\Cygwin\mounts v2\/
  (default) = 'C:\Cygwin-Linux'
  flags = 0x0000000a
HKEY_LOCAL_MACHINE\SOFTWARE\Cygnus Solutions\Cygwin\mounts v2\/usr/bin
  (default) = 'C:\Cygwin-Linux/bin'
  flags = 0x0000000a
HKEY_LOCAL_MACHINE\SOFTWARE\Cygnus Solutions\Cygwin\mounts v2\/usr/lib
  (default) = 'C:\Cygwin-Linux/lib'
  flags = 0x0000000a
HKEY_LOCAL_MACHINE\SOFTWARE\Cygnus Solutions\Cygwin\Program Options

a:  fd             N/A    N/A                   
c:  hd  NTFS     39197Mb  97% CP CS UN PA FC     System
d:  hd  FAT32    78140Mb  40% CP    UN           DIVERS
e:  cd             N/A    N/A                   
f:  cd             N/A    N/A                   
g:  cd             N/A    N/A                   

C:\Cygwin-Linux      /          system  binmode
C:\Cygwin-Linux/bin  /usr/bin   system  binmode
C:\Cygwin-Linux/lib  /usr/lib   system  binmode
.                    /cygdrive  system  binmode,cygdrive

Not Found: awk
Not Found: bash
Found: C:\SFU\common\cat.exe
Found: C:\SFU\common\cp.exe
Not Found: cpp (good!)
Found: C:\SFU\common\crontab.exe
Found: C:\SFU\common\find.exe
Not Found: gcc
Not Found: gdb
Found: C:\SFU\common\grep.exe
Found: C:\SFU\common\kill.exe
Not Found: ld
Found: C:\SFU\common\ls.exe
Not Found: make
Found: C:\SFU\common\mv.exe
Not Found: patch
Not Found: perl
Found: C:\SFU\common\rm.exe
Found: C:\SFU\common\sed.exe
Not Found: ssh
Not Found: sh
Not Found: tar
Not Found: test
Found: C:\SFU\common\vi.exe
Not Found: vim

   61k 2006/11/10 C:\Cygwin-Linux\bin\cygbz2-1.dll - os=4.0 img=1.0 sys=4.0
                  "cygbz2-1.dll" v0.0 ts=2006/11/10 18:42
    7k 2003/10/19 C:\Cygwin-Linux\bin\cygcrypt-0.dll - os=4.0 img=1.0 
                  "cygcrypt-0.dll" v0.0 ts=2003/10/19 3:57
   40k 2006/11/15 C:\Cygwin-Linux\bin\cygform-8.dll - os=4.0 img=1.0 sys=4.0
                  "cygform-8.dll" v0.0 ts=2006/11/15 2:06
   25k 2008/01/04 C:\Cygwin-Linux\bin\cyghistory6.dll - os=4.0 img=1.0 
                  "cyghistory6.dll" v0.0 ts=2008/1/3 22:31
  271k 2007/08/24 C:\Cygwin-Linux\bin\cygicons-0.dll - os=4.0 img=1.0 
                  "cygicons-0.dll" v0.0 ts=2007/8/24 3:24
  976k 2006/10/22 C:\Cygwin-Linux\bin\cygiconv-2.dll - os=4.0 img=1.0 
                  "cygiconv-2.dll" v0.0 ts=2006/10/22 19:44
   31k 2005/11/20 C:\Cygwin-Linux\bin\cygintl-3.dll - os=4.0 img=1.0 sys=4.0
                  "cygintl-3.dll" v0.0 ts=2005/11/19 21:04
   31k 2006/10/23 C:\Cygwin-Linux\bin\cygintl-8.dll - os=4.0 img=1.0 sys=4.0
                  "cygintl-8.dll" v0.0 ts=2006/10/22 20:12
   21k 2006/11/15 C:\Cygwin-Linux\bin\cygmenu-8.dll - os=4.0 img=1.0 sys=4.0
                  "cygmenu-8.dll" v0.0 ts=2006/11/15 2:05
   67k 2006/11/15 C:\Cygwin-Linux\bin\cygncurses++-8.dll - os=4.0 
img=1.0 sys=4.0
                  "cygncurses++-8.dll" v0.0 ts=2006/11/15 2:13
  237k 2006/11/15 C:\Cygwin-Linux\bin\cygncurses-8.dll - os=4.0 img=1.0 
                  "cygncurses-8.dll" v0.0 ts=2006/11/15 2:02
   12k 2006/11/15 C:\Cygwin-Linux\bin\cygpanel-8.dll - os=4.0 img=1.0 
                  "cygpanel-8.dll" v0.0 ts=2006/11/15 2:04
  133k 2007/06/27 C:\Cygwin-Linux\bin\cygpcre-0.dll - os=4.0 img=1.0 sys=4.0
                  "cygpcre-0.dll" v0.0 ts=2007/6/26 23:49
  303k 2007/06/27 C:\Cygwin-Linux\bin\cygpcrecpp-0.dll - os=4.0 img=1.0 
                  "cygpcrecpp-0.dll" v0.0 ts=2007/6/26 23:50
    7k 2007/06/27 C:\Cygwin-Linux\bin\cygpcreposix-0.dll - os=4.0 
img=1.0 sys=4.0
                  "cygpcreposix-0.dll" v0.0 ts=2007/6/26 23:50
   22k 2002/06/09 C:\Cygwin-Linux\bin\cygpopt-0.dll - os=4.0 img=1.0 sys=4.0
                  "cygpopt-0.dll" v0.0 ts=2002/6/9 1:45
  155k 2008/01/04 C:\Cygwin-Linux\bin\cygreadline6.dll - os=4.0 img=1.0 
                  "cygreadline6.dll" v0.0 ts=2008/1/3 22:31
 1829k 2007/12/14 C:\Cygwin-Linux\bin\cygwin1.dll - os=4.0 img=1.0 sys=4.0
                  "cygwin1.dll" v0.0 ts=2007/12/14 13:22
    Cygwin DLL version info:
        DLL version: 1.5.25
        DLL epoch: 19
        DLL bad signal mask: 19005
        DLL old termios: 5
        DLL malloc env: 28
        API major: 0
        API minor: 156
        Shared data: 4
        DLL identifier: cygwin1
        Mount registry: 2
        Cygnus registry name: Cygnus Solutions
        Cygwin registry name: Cygwin
        Program options name: Program Options
        Cygwin mount registry name: mounts v2
        Cygdrive flags: cygdrive flags
        Cygdrive prefix: cygdrive prefix
        Cygdrive default prefix:
        Build date: Fri Dec 14 19:21:07 CET 2007
        CVS tag: cr-0x5f1
        Shared id: cygwin1S4

   52k 2007/08/19 C:\Program Files\MKVtoolnix\cygz.dll - os=4.0 img=1.0 
                  "cygz.dll" v0.0 ts=2004/1/8 8:31

Can't find the cygrunsrv utility, skipping services check.

Cygwin Package Information
Last downloaded files to: D:\Temp\cygwin-old\install files
Last downloaded files from: D:\Temp\cygwin-old\install files

Package              Version
_update-info-dir     00581-1
alternatives         1.3.29a-1
ash                  20040127-3
base-files           3.7-1
base-passwd          2.2-1
bash                 3.2.33-18
bzip2                1.0.3-2
coreutils            6.10-1
crypt                1.1-1
cygutils             1.3.2-1
cygwin               1.5.25-7
cygwin-doc           1.4-4
editrights           1.01-2
findutils            4.3.13-1
gawk                 3.1.6-1
grep                 2.5.1a-4
groff                1.18.1-2
gzip                 1.3.12-2
less                 382-1
libbz2_1             1.0.3-2
libiconv2            1.11-1
libintl3             0.14.5-1
libintl8             0.15-1
libncurses8          5.5-3
libpcre0             7.2-1
libpopt0             1.6.4-4
libreadline6         5.2.12-10
login                1.9-7
man                  1.6e-1
rebase               2.4.3-1
run                  1.1.10-1
sed                  4.1.5-2
tar                  1.19-1
termcap              20050421-1
terminfo             5.5_20061104-1
texinfo              4.8a-1
tzcode               2007h-2
which                2.19-1
Use -h to see help about each section
--------- End of output ------

Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/

More information about the Cygwin mailing list