Stop Brute Force Attack on SSH

Kyle A. Dawson
Mon Feb 18 03:51:00 GMT 2008

Sorry, my mistake.  I created a script, and the file had windows new
lines... I always forget that with TextPad.  But I did read the readme and
now I have these files:


So the install/config seem to work.  

When I start this I get error (/var/log/denyhost.log):

DenyHosts could not obtain lock (pid: )
[Errno 2] No such file or directory: '/var/lock/subsys/denyhosts'
starting DenyHosts:    /usr/bin/env python /usr/bin/ --daemon

The service will not start, just the above message in log.

Here is what I run
cygrunsrv -I DenyHosts -p /usr/share/denyhosts/daemon-control -a start  -d
DenyHosts -f "DenyHosts 2.6"  -y sshd -x /var/run/ -o
cygrunsrv -S DenyHosts

I removed the \ in the "-a start option", it did not like that.  Is it

-----Original Message-----
From: René Berber [] 
Sent: Sunday, February 17, 2008 9:03 PM
To: Kyle A. Dawson
Subject: Re: Stop Brute Force Attack on SSH

Kyle A. Dawson wrote:

> The install worked great. But when I try to create the service:
> cygrunsrv -I DenyHosts -p /usr/share/denyhosts/daemon-control -a start -d
> DenyHosts -f "DenyHosts 2.6"  -y sshd -x /var/run/ -o
> I get this:
> cygrunsrv: unknown option --
> Also, this does not exist:
> /usr/share/denyhosts/daemon-control

Let's start on this last one.

The installation showed where things are setup, most end up in 
/usr/lib/python2.5/site-packages/DenyHosts, then there is 
/bin/, and finally the 'workdir' /usr/share/denyhosts, do 
you see anything in there?

Daemon-cotrol is a python script, in a listing it should show as 
executable (no extension)... oh, wait a minute, I see a 
daemon-control-dist maybe the installation steps included a copying of 
that one into daemon-control and then edit... yes, I forgot about it, 
but it is in the README.txt in that directory.

Now about the first problem, I can't see where the '--' comes from, do 
you have a recent version of cygrunsrv?  I see:

$ cygrunsrv --version
cygrunsrv V1.18, Jan 21 2008

And if you look at the options with 'cygrunsrv --help', all of them are 
correct.  Of course there is a problem when 'daemon-control' doesn't exist.
René Berber

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list