SSHD Passwordless - Connection closed

victor hooi
Tue Feb 26 09:19:00 GMT 2008

NB: I found this:

which had a similar issue, but not quite the same,

I have a Windows box  I'm attempting to back up using
RSnapshot, running cwrsync and Cygwin sshd

The client from which we're running Rsnapshot is a
Linux box.

On the Linux box, I've generated a keyset using:

	ssh-keygen -t rsa

and a blank passphrase.

I copied to the Windows box, and added the
key to "authorized_keys" in "C:\Documents and

On the Linux box, trying to log in using "ssh
Administrator@windowsbox", I get:

debug1: SSH2_MSG_SERVICE_ACCEPT received
debug2: key: /root/.ssh/identity ((nil))
debug2: key: /root/.ssh/id_rsa (0x5dd10)
debug2: key: /root/.ssh/id_dsa ((nil))
debug1: Authentications that can continue:
debug3: start over, passed a different list
debug3: preferred
debug3: authmethod_lookup publickey
debug3: remaining preferred:
debug3: authmethod_is_enabled publickey
debug1: Next authentication method: publickey
debug1: Trying private key: /root/.ssh/identity
debug3: no such identity: /root/.ssh/identity
debug1: Offering public key: /root/.ssh/id_rsa
debug3: send_pubkey_test
debug2: we sent a publickey packet, wait for reply
Connection closed by

I've tried going the other way - generating a keypair
on the Windows box using the cygwin version of
ssh-keygen, copying cygwin's to the Linux
box, and adding it to root's .ssh/authorized_keys.
That worked fine.

I've tried the Linux keypair in loopback - that is,
copying the Linux box's public key ( to
it's own authorized_keys, and logging in to localhost,
passwordlessly. That worked fine.

In the Event Log on the Windows box, I have:

The description for Event ID ( 0 ) in Source ( sshd )
cannot be found. The local computer may not have the
necessary registry information or message DLL files to
display messages from a remote computer. You may be
able to use the /AUXSOURCE= flag to retrieve this
description; see Help and Support for details. The
following information is part of the event: sshd: PID
3608: fatal: seteuid 500: No such process.

Any help at all would be fantastic.

Also, I've blown my .ssh directory away a few times,
and re-generated the keys with ssh-keygen, there's
nothing wrong with doing that, is there?


Never miss a thing.  Make Yahoo your home page.

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list