[ANNOUNCEMENT] Updated: [experimental] cygwin-1.5.25-8

Fredrik Staxeng fstx+u@update.uu.se
Tue Feb 26 14:18:00 GMT 2008

Corinna Vinschen <corinna-cygwin@cygwin.com> writes:

>On Feb 26 07:33, Fredrik Staxeng wrote:
>> I am trying to run cygwin on Windows Server 2008, under Hyper-V, accessing
>> via Remote Desktop.
>> I somehow succeeded in installing 1.5.25-7, then I upgraded to 
>Yes, that works on the 64 bit version.  You only get the problems
>> the experimental 1.5.25-8. When I try to start X programs, sometimes
>> it succeeds, but mostly I get a message like this:
>> 31089349 [main] xstart 2204 child_copy: linked dll data write copy failed, 
>> 0x319000..0x31CF40, done 0, windows pid 2816, Win32 error 487
>You probably have to rebase.
>> BTW, is there an easy way to check what version of the cygwin1.dll one is 
>> running? 
>uname -a.  The 1.5.25-8 version has a build date 2008-02-22
>1.5.25-7 is from 2007-12-14.

I got it to work. Here is what I did for the archives:

I ran setup.exe twice, first to install what I wanted to have, then
again to upgrade cygwin-base to 1.5.25-8. Then I ran
c:\cygwin\ash.exe, and ran /bin/rebaseall in that.

When fiddling with setup.exe I noticed that if the 'Cur' radio button
is selected, you can select the 1.5.25-8 version, but as soon as you
do something else, the selection flips back to 1.5.25-7! On the other
hand, if you select 'Exp', all sorts of necessary stuff gets flipped
to 'Skip'.

Fredrik Stax\"ang | rot13: sfgk@hcqngr.hh.fr
This is all you need to know about vi: ESC : q ! RET

Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/

More information about the Cygwin mailing list