mc problems

Mikolaj Machowski
Tue Feb 26 22:53:00 GMT 2008


I am trying use mc on my installation of cygwin. But I have problem with
Polish diacritics in file names.

mc doesn't display them correctly at all and I cannot input several of them
into command line.

The same problem exists under Linux but after downloading latest version
from CVS and compiling with --enable-charset --enable-extcharset options it
was solved.

I done the same. BTW - much kudos to Cygwin and mc developers. Vanilla mc
sources from CVS compiled without big problems on Cygwin.

Minor problem was with iconv. mc couldn't find libiconv - had to install
libiconv package in addition to libiconv2. Some naming problem? Shouldn't 
it something like libiconv-devevl?

But there are still two problems:

- on Linux after compiling with charset options dialog for "display bits"
changes from menu:

(*) Full 8-bits output
( ) ISO 8859-1
( ) 7 bits
[x] Full 8 bits input

to dropdown menu when I can explicitly select which encoding I want to use.
When selecting proper encoding (in my case ISO 8859-2) all problems with
encoding vanish. That is on Linux. On Cygwin old dialog stays.

- mc is terribly slow when starting + zsh is going into overdrive. CPU 
jumps to 30% and whole computer significantly slows down (and this doesn't
stop after closing mc, to stop that I have to shell where mc was started).
But this is not the case with Cygwin mc. Should I adjust compilation
somehow? OK - "solved" - had to completely disable subshell.

Still more important for me is encoding problem. Maybe it can be solved on
Cygwin level somehow? But I don't know which value should I set.

Native Polish encoding for Windows is cp1250.
But console encoding is cp852.

I should add that input of Polish diacritics in command line is OK, there
are problems with displaying of them but applications understand them - eg
zsh command line completion works as I should expect.

What and where should I set?



Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list