Fw: patch command giving permission denied

Corinna Vinschen corinna-cygwin@cygwin.com
Mon Mar 2 09:47:00 GMT 2009


On Mar  1 23:08, Sjors Gielen wrote:
> Aaron Gray schreef:
>> On Sat, Feb 28, 2009 at 1:30 AM, Aaron Gray  
>> <aaronngray.lists@googlemail.com> wrote:
>>> I am getting the following on executing the patch command :-
>>>
>>>  bash: /usr/bin/patch: Permission Denied
>>>
>>> It works on my other Vista machine okay (That is an Enterprise one  
>>> rather than a Home version)
>>>
>>> Anyone got any ideas why and how to fix it
>>
>> It works fine on my other Vista Home machine.
>> It works okay if I run cygwin bash as an administrator.
>> Why is this machine behaving differently and how do I fix it ?
>> I tried reloading Cygwin from scratch, but that did not help.
>>
>> Aaron
>
> I had this problem too. It's because of the new UAC in Windows. You need  
> to add a .manifest file, because patch.exe contains one of "install",  
> "setup" and "patch", which UAC does not trust right away. It's  

The latest patch package 2.5.8-9 comes already with a manifest file.


Corinna

-- 
Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Project Co-Leader          cygwin AT cygwin DOT com
Red Hat

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list