Utility installation problem - diff (diffutils)

Christopher Faylor cgf-use-the-mailinglist-please@cygwin.com
Tue Mar 10 18:39:00 GMT 2009


On Tue, Mar 10, 2009 at 06:08:16AM -0700, Philippe Gibelin wrote:
>When we installed Cygwin, we noticed that the "diff" utility wasn't installed by default. We then installed diffutils, and diff crashed when a run was attempted from the Cygwin shell. From the Windows command prompt, it gave an error "missing dll (cygintl-2.dll)". We tried to find cygintl-2.dll in the cygwin web, and it is supposed to be in libintl2 package. We looked in a mirror site, and that package wasn't there.
>
>We then installed the Red Hat version, which included that file (cygintl-2.dll), so we copied it to the normal cygwin installation, and diff worked!
>
>This would seem to be an installation problem with cygwin....

diffutils relies on libintl2 which provides cygintl-2.dll so there is no
packaging problem.  I don't know why libintl2 was not installed on your
system unless it was specifically deselected.

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list