under cygwin, zsh cannot run when built against ncurses9-5.7-13

René Berber r.berber@computer.org
Sat Mar 14 04:39:00 GMT 2009


Vin Shelton wrote:

> Charles Wilson wrote:
>> Just for grins, could you rebuild zsh against libncurses9 -- but this
>> time use gcc3?  cygiconv-2 and cygncurses-9 use the static gcc-3.4.4
>> libgcc.a, but you are apparently using the gcc-4.3.2 shared libgcc.
>>
>> I just wonder if that presents an incompatibility that could explain
>> what you are seeing.
> 
> Thanks for replying, Chuck.
> 
> As I mentioned in the initial email, I had already done just that.  Just
> to be sure, I did it again, with the same result:

No you didn't, the point was: use gcc3, in other words: mixing libraries
built with gcc3 and gcc4 doesn't work.
-- 
R.Berber


--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list