'less': <HOME><END> not working with 'mintty' > v0.3.6

Lee D.Rothstein lee@veritech.com
Wed Mar 25 07:40:00 GMT 2009


I hope I've got this right, but lately I seem to be so confused by the 
differences between Cygwin 1.5 & 1.7, that I'm not sure.

I believe that the settings we had previously discussed to get 'less' to 
<HOME> & <END> as beginning and end of stream respectively,
stopped working with the 'mintty' v0.3.7 release.

And this is true for both Cygwin v1.5 and v1.7.

My .lesskey file is:
# Activate mousewheel scrolling in 'less' with the following two
# lines in your .lesskey file. Run 'lesskey' to compile this
# file into 'less' internal format.
\eO1;2A back-line # <UP-ARROW>
\eO1;2B forw-line # <DOWN-ARROW>
\eOH goto-line # <HOME> -- Beginning of input
\eOF goto-end  # <END> -- End of input
I tried a fresh recompile under Cygwin v1.7, with 'mintty' v0.3.8, to
no avail.

However, I thought the above settings worked with 'xterm' as well.
They do not.


Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/

More information about the Cygwin mailing list