Hopefully new details on the rsync crash issue

Jon Sjöstedt jonsjostedt@gmail.com
Wed Mar 25 14:27:00 GMT 2009

Hello all!

As many others, I also have problems using rsync in cygwin. I hope
adding my case can help some expert  find the source problem. If more
tests are desired, I will conduct them.

I have an OpenBSD4.4-box with rsync 3.0.3. rsync is running in daemon
mode and is started by inetd. I have defined four simple sections in
rsyncd.conf (only name and comment) that are readonly (that is, I wish
to copy FROM the daemon-box TO a client-box).

In the other corner: XP Pro SP3 with latest cygwin-components. On this
machine, I run the cygwin-rsync from a windows batch-file. I have
tried both using a ssh tunnel and running rsync "naked". I access the
rsync resources simplest possible like rsync.exe -r
host::rsyncnode/somefile /cygdrive/driveletter/path. The XP-box is
otherwise stable.

These boxes are alone on a 100Mb local network that work very well
with SAMBA, ssh, web and other applications.

After some time the rsync client hangs the XP-box. The hang is solid
and neither Ctrl-Alt-Delete, NumLock or the Mouse pointer works. A
cold boot is requied. The hang always occour when new files are
processed and all new attempts go a bit further than a previous one.
More specifically for my case: I try to copy a large set of large
files (> 5000 files and many of them >100MB), ca 300GB in total. I
have done 5-10 attempts and the space used on the destination drive is
increased by 4-6GB per try.

Any ideas? Need more info?


Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/

More information about the Cygwin mailing list