gtk with win32 backend (not X11)

Dave Korn
Sat Mar 28 17:39:00 GMT 2009

Kasper Peeters wrote:

> Has anyone had success compiling the gtk toolkit under cygwin using
> the Win32 backend? I am getting as far as building&installing glib,
> atk and cairo (the cairo tests run fine, too). After that, the pango
> configure script does pick up that it should build for "Cairo Win32"
> and it does say "enabled shared libraries: yes", but the build process
> never creates any dlls (there is no error either though, only the
> static ".a" libraries and the ".la" files get produced & installed).
> I have tried various older versions and also tried a 'libtoolize' to
> refresh the libtool scripts, but none of that made any difference.

  Most common cause of this problem is that libtool doesn't build DLLs on
Cygwin by default, because an awful lot of *nix shared objects rely on
undefined symbols that get dynamically resolved at load-time, a facility that
is not (yet![*]) supported on windows platforms.

  To tell libtool that a library won't have any unresolved references left
over after linking and so it's ok to build it as a DLL, you need to add
"-no-undefined" to the LDFLAGS used when linking the library.  This is
generally in the form of a variable named xxxxxxx_la_LTLDFLAGS somewhere in
the template.


Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list