Xterm font resizing broken and input problems in xorg-server 1.5.3-7

Alex Epshteyn alexander.epshteyn@gmail.com
Sun Mar 29 00:25:00 GMT 2009

Yep, separately installing the font-* packages with setup.exe solved
my problem with the font sizes.  I also haven't seen the no input
problem since, but it was a sporadic issue to begin with, so I don't
know if that fixed it as well.

On Sat, Mar 28, 2009 at 1:10 PM, Alex Epshteyn
<alexander.epshteyn@gmail.com> wrote:
> I realized that there are some startup errors I wasn't seeing by using
> the windows shortcut.  Here's what starting xterm on the command line
> prints out:
> xterm -display -ls
> Warning: Cannot convert string
> "-adobe-helvetica-bold-r-normal--*-120-*-*-*-*-iso8859-*" to type
> FontStruct
> Warning: Cannot convert string "nil2" to type FontStruct
> xterm: cannot load font 10x20
> I also realized, after some more Googling, that the fonts packages are
> no longer included in the distro the same way as before.  I'm trying
> to fix the problem by installing all the font-* packages now.  Will
> let you know if that worked.
> On Sat, Mar 28, 2009 at 12:01 PM, Alex Epshteyn
> <alexander.epshteyn@gmail.com> wrote:
>> I just upgraded my Cygwin distro, and I'm having the following issues
>> with x-term:
>> 1) cannot input text into any additional xterm window launched by my
>> start menu shortcuts.  The only xterm window that works is the default
>> one that comes up when I start x-server.
>> 2) cannot change the font size in ANY xterm window.  Neither by
>> ctrl+rightclick nor the (newly added) menu bar.  Selecting any font
>> size from the menu doesn't have any effect.  (Prior to the upgrade I
>> had the default font set to Huge but now it comes up with the
>> original, small, default font).
>> I'm running on Win XP, with xorg-server 1.5.3-7 and xterm 242-1.
>> Never had any of these problems before this upgrade (my original
>> install was from March '08).  I'm attaching cygcheck.out for more
>> details on my system (note: some path variables deleted for privacy
>> reasons)
>> The only relevant hit I found on Google is this, which it seems,
>> describes the same problem (however his solution of appending  -fn
>> '*12*' to the command line didn't work for me):
>> http://www.nomadjourney.com/2008/12/xterm-font-sizing-problems-in-cygwin/
>> Alex

Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/

More information about the Cygwin mailing list