Help with proftpd configuration for local Cygwin package repo or bug in setup.exe.

Oleksandr Gavenko gavenko@bifit.com.ua
Tue Aug 3 14:38:00 GMT 2010


I run proftpd 1.3.0-19 on Debian Etch where I put by rsync Cygwin 
package mirror.

When I run setup.exe:

setup.exe --quiet-mode --only-site --site ftp://192.168.1.38/cygwin 
--packages emacs

it stop on:

Starting cygwin install, version 2.697
io_stream_cygfile: fopen(/etc/setup/net-proxy-host) failed 2 No such 
file or directory
io_stream_cygfile: fopen(/etc/setup/net-proxy-port) failed 2 No such 
file or directory
io_stream_cygfile: fopen(/etc/setup/extrakeys) failed 2 No such file or 
directory
Current Directory: D:\home\devel\tmp
User has backup/restore rights
Changing gid to Administrators
Could not open service McShield for query, start and stop. McAfee may 
not be installed, or we don't have access.
root: C:\opt\cygwin binary system
Selected local directory: D:\home\devel\tmp
net: Direct
Cached mirror list unavailable
Defaulting to empty mirror list
site: ftp://192.168.1.38/cygwin
get_url_to_membuf ftp://192.168.1.38/cygwin/setup.bz2
getUrlToStream ftp://192.168.1.38/cygwin/setup.bz2
ftp > 220 ProFTPD 1.3.1 Server (Debian) [192.168.1.38]
ftp > 331 Anonymous login ok, send your complete email address as your 
password
ftp > 230 Anonymous access granted, restrictions apply
ftp > 200 Type set to I
ftp > 227 Entering Passive Mode (192,168,1,38,215,177).
ftp > 150 Opening BINARY mode data connection for /cygwin/setup.bz2 
(262643 bytes)

Downloading status bar not changed from 0%.

By wget --no-proxy ftp://192.168.1.38/cygwin/setup.bz2 I successfully 
get setup.bz2.
Passive ftp mode also work.

With older setup.exe version (I get it with Cygwin 1.7.1):  2.686 all 
work successfully.

New version work successfully when  I put  repo to Windows host with 
FileZilla.

My proftpd config (only corresponding part):

<Anonymous /srv/ftp/pub>
   User              ftp
   Group             nogroup
   UserAlias         anonymous ftp
   DirFakeUser   on ftp
   DirFakeGroup on ftp
   RequireValidShell     off
   MaxClients            40
   <Directory *>
     <Limit WRITE>
       DenyAll
     </Limit>
   </Directory>
</Anonymous>


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list