Cygwin 1.7.5 segfault during setup

Steve Marotta smarotta@gmail.com
Mon Aug 16 21:32:00 GMT 2010


I am using Cygwin 1.7.5, upgraded from 1.5, or so I think. I am trying
to run setup.exe so I can install new packages. I select "Install from
Internet" and "Direct Connection", and my network connection itself
works fine. When setup tries to download the mirrors list, it says,
"This application has requested the Runtime to terminate it in an
unusual way."

I tried running it under gdb, but without debug symbols, it didn't do
much good. Here's the output:

********************************************************
Starting program: c:/Documents and Settings/smarotta.CRA/My
Documents/downloads/setup-1.7.5.exe
Loaded symbols for C:\WINDOWS\system32\ntdll.dll
Loaded symbols for C:\WINDOWS\system32\kernel32.dll
Loaded symbols for C:\WINDOWS\system32\advapi32.dll
Loaded symbols for C:\WINDOWS\system32\rpcrt4.dll
Loaded symbols for C:\WINDOWS\system32\secur32.dll
Loaded symbols for
C:\WINDOWS\WinSxS\X86_Microsoft.Windows.Common-Controls_6595b64144ccf1df_6.0.2600.5512_x-ww_35d4ce83\comctl32.dll
Loaded symbols for C:\WINDOWS\system32\msvcrt.dll
Loaded symbols for C:\WINDOWS\system32\gdi32.dll
Loaded symbols for C:\WINDOWS\system32\user32.dll
Loaded symbols for C:\WINDOWS\system32\shlwapi.dll
Loaded symbols for C:\WINDOWS\system32\ole32.dll
Loaded symbols for C:\WINDOWS\system32\shell32.dll
Loaded symbols for C:\WINDOWS\system32\wsock32.dll
Loaded symbols for C:\WINDOWS\system32\ws2_32.dll
Loaded symbols for C:\WINDOWS\system32\ws2help.dll
warning: LOG: 2 Starting cygwin install, version 2.697
warning: LOG: 2 io_stream_cygfile: fopen(/etc/setup/net-proxy-host)
failed 2 No such file or directory
warning: LOG: 2 io_stream_cygfile: fopen(/etc/setup/net-proxy-port)
failed 2 No such file or directory
warning: LOG: 2 io_stream_cygfile: fopen(/etc/setup/extrakeys) failed
2 No such file or directory
warning: LOG: 2 io_stream_cygfile:
fopen(/etc/setup/chooser_window_settings) failed 2 No such file or
directory
warning: LOG: 2 Current Directory: C:\Documents and Settings\smarotta\Home\temp
warning: LOG: 2 User has backup/restore rights
warning: LOG: 2 Changing gid to Administrators
warning: LOG: 2 Could not open service McShield for query, start and
stop. McAfee may not be installed, or we don't have access.
warning: LOG: 2 source: network install
warning: LOG: 2 root: C:\cygwin binary system
warning: LOG: 2 Selected local directory: C:\Documents and
Settings\smarotta\Home\temp
warning: LOG: 2 net: Direct
warning: LOG: 1 Loaded cached mirror list
warning: LOG: 1 get_url_to_membuf http://cygwin.com/mirrors.lst
warning: LOG: 1 getUrlToStream http://cygwin.com/mirrors.lst

Program exited with code 03.
********************************************************

Is there a problem with the cached mirrors list? Can I clear that
cache? Can it be the .NET framework I have installed on my machine? I
would appreciate any and all ideas anyone has on how to resolve this
issue, as I need to use Cygwin as soon as possible.

Thanks,
Steve

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list