cygwin 1.7.6: find skipping over some directories on NTFS mount points

Corinna Vinschen corinna-cygwin@cygwin.com
Thu Aug 19 08:38:00 GMT 2010


On Aug 19 10:31, Corinna Vinschen wrote:
> On Aug 18 18:50, Rolf Campbell wrote:
> > I have an 2nd NTFS disk mounted in a directory in my primary NTFS
> > disk.  When I use 'find' (with no arguments), it only displays a
> > small fraction of the files in the current directory.
> > 
> > Using cygwin 1.7.5, it displayed about 100,000 files.
> > Using cygwin 1.7.6, it only displays the content of the first
> > top-level directory and then just stops.
> > 
> > I tried out all the snapshots and narrowed it down to "20100618".
> > It worked correctly in "20100614" and does not work correctly in
> > "20100618".
> >
> > If I mount the disk as a normal drive and access it using
> > "/cygdrive", it displays all 100,0000 files with both 1.7.5 and
> > 1.7.6.
> 
> That narrows down the problem to a specific change, but unfortunately
> I can not reproduce the problem.
> 
> I assume, when you say you "mounted" the 2nd drive, you didn't mean a
> Cygwin mount but rather a Windows junction point, so your drive doesn't
> show up as D:, but as C:\DriveD in Windows, correct?
> 
> At least, that's what I tested.  The drive has 1577 files and
> directories in multiple levels, and `find' always prints all of them,
> regardless whether the drive is mounted as drive or as juntion point.
> I also tried a Cygwin mount additionally, with the same result.
> 
> Here are a couple of questions.  They are all related to the mount
> using a junction point.
> 
> - When you call `ls -l' in the top-level dir of the junction point,
>   are directories recognized as directories?
>   How many links do the directories supposedly have (should be 1)?
> 
> - Is it possible that this has something to do with permissions?
>   "acl" vs. "noacl".  Your cygcheck output doesn't point that out,
>   but who knows.
> 
> - Eventually, under Cygwin 1.7.6, can you please send us the output of
>   `ls -l' of the top-level dir, and call `strace -o find.trace find' in
>   the top-level dir and send the strace output?  Please don't try this
>   with the *working* scenario, the strace of a find finding 100000 files
>   would be a bit... swollen.

Hmm, is it perhaps possible that this is a side effect of running some
aggressive virus scanner which needs tweaking?  It's very strange that
it should make a difference, whether the drive is mounted as drive or
as junction point.  There's no difference from Cygwin's POV, and the
content of the drive obviously doesn't change by this.  Therefore...
well, it's grasping for straws, but still...


Corinna

-- 
Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Project Co-Leader          cygwin AT cygwin DOT com
Red Hat

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list