Postinstall error (partly solved)

Buchbinder, Barry (NIH/NIAID) [E] BBuchbinder@niaid.nih.gov
Mon Aug 23 23:31:00 GMT 2010


Milos Puchta sent the following at Monday, August 23, 2010 2:22 PM
>Hello
>	boxes.sh exit code 2
>	libglade2.0.sh exit code 3
>	exim.sh exit code 1
>	mined.sh exit code 1
>	boxes.sh exit code 2
>	exim.sh exit code 1
>	libglade2.0.sh exit code 3
>	mined.sh exit code 1
>
>I had created by mc new directory \etx\xml and postinstall has not
>announce any error concerning xml documents. However some error
>persists: Package: boxes Package: libglade2.0_0 Package: exim Package:
>mined Package: No package
>
>Has anyone a hint how to cure boxes, libglade2, exim and mined?

My suggestion:

Open a terminal (bash or your shell of preference).

Go to /etc/postinstall

Edit each of the scripts, adding "-x" to the end of the "shebang" line.

Run the script.

That should show you what command is giving the error.  The error message
may also indicate why it is giving the error.

For what it's worth (probably not much), my experience was related to
permissions.  However, you may have an unrelated cause, so consider other
possibilities.

If an application seems to be working OK, or you figure out the problem and
correct it manually (without the script) you might consider renaming
script.sh to script.sh.done to get setup to stop trying to run the script.

Good luck,

- Barry
  Disclaimer: Statements made herein are not made on behalf of NIAID.


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list