Building Mutt: configure: invalid value of canonical build

Michael Ludwig milu71@gmx.de
Mon Aug 30 22:59:00 GMT 2010


The mutt mail reader shipping with Cygwin does not have SMTP enabled,
which I'd like to give a try. So I tried to build mutt, but encountered
problems.

The machine is 64-Bit PC running Win7/64/Pro, and Cygwin, of course.

I have both gcc 3 and 4 installed.

  ./configure --prefix=/usr/local/mutt --build=i686-pc \
    --enable-imap --enable-smtp --enable-hcache --with-regex --with-ssl

Note that I specified a (wrong) --build option, but read on and see
below. Independently of that --build option, I got the following error:

  configure: error: cannot run /bin/sh ./config.sub

The solution is easy:

  touch config.sub

Got the same for install-sh, by the way.

Now on to the main error. Trying again the same configure line.

          \,,,/
          (o o)
------oOOo-(_)-oOOo------
checking whether build environment is sane... yes
/bin/sh: /usr/src/mutt-1.5.20-1.milu/orig/missing: No such file or directory
configure: WARNING: `missing' script is too old or missing
... [don't know if the above is a problem]
...
checking build system type...
configure: error: invalid value of canonical build
-------------------------

It is only after receiving an error because of the script's failure to
guess the build system that I added the --build option to configure.
But obviously I didn't fill in a correct value. What should I try?

-- 
Michael Ludwig

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list