Segmentation Fault in OpenGL - glutMainLoop

Nathan Rose NROSE@groupwise.swin.edu.au
Wed Dec 1 11:00:00 GMT 2010


Hi all,

I suspect this problem may be beyond the scope of this mailing list, but I would really appreciate any help that you could provide. 
 
I have someone else's code that uses OpenGL (it's a massive set of files, so I'm not going to attach them here). It compiles fine on Cygwin, but when the glutMainLoop method is called I get a segmentation fault. I have tested it on Ubuntu and this does not occur there, so my assumption is that there is something wrong with how I have set up Cygwin. The following packages have been installed: 
libglut-devel
freeglut
libglut3
opengl
glproto
libGL-devel
libGL1
libGLU-devel
libGLU1
libglitz
libxcb-dlx-devel
libxcb-glx0
(basically, I've installed everything from the Select Packages page that has 'gl' in its name)

I have attached the stackdump from the segfault and the output from cygcheck, in case they can help identify the cause of this issue. I'm not expecting that anyone will be able to magically solve this with what little information I have provided, but any hints as to which direction I should proceed would be appreciated.

Thanks,

Nathan

-------------- next part --------------
A non-text attachment was scrubbed...
Name: test.exe.stackdump
Type: application/octet-stream
Size: 952 bytes
Desc: not available
URL: <http://cygwin.com/pipermail/cygwin/attachments/20101201/c4cdb93f/attachment.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: cygcheck.out
Type: application/octet-stream
Size: 48587 bytes
Desc: not available
URL: <http://cygwin.com/pipermail/cygwin/attachments/20101201/c4cdb93f/attachment-0001.obj>
-------------- next part --------------
--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple


More information about the Cygwin mailing list