Setup bug? Looping through requisites

Buchbinder, Barry (NIH/NIAID) [E] BBuchbinder@niaid.nih.gov
Fri Dec 10 17:17:00 GMT 2010


First, let me start with gratitude and a complement.  Overall, I
LIKE that speed improvements in setup.  Thanks for all the work
that went into it!

Now, a bug report.

This morning setup when into a loop while checking requisites.

It was start by a batch file that called a windows shortcut with
the following command line
    C:\cygwin\usr\local\bin\setup.exe -R c:\cygwin -n -q -l h:\cygwin\arc

I then started it manually and clicked through the screens.  It worked
OK except for stopping to ask permission needing to add something that
was missing - I think that it was <libevtlog0>.

Here is what it downloaded
    _update-info-dir-00933-1
    libevtlog0-0.2.12-1
    libglpk0-4.45-1

Since then I've run the shortcut again and it worked fine.  Of course,
nothing needed to be updated.

I've attached <setup.log full> and, in <setup.log.last3>, the last 3
updates as listed in <setup.log>.  I apologize for not having thought
to save <setup.log> before running setup again.

Thanks again,

- Barry
  Disclaimer: Statements made herein are not made on behalf of NIAID.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: setup.log.full
Type: application/octet-stream
Size: 13260 bytes
Desc: setup.log.full
URL: <http://cygwin.com/pipermail/cygwin/attachments/20101210/edab5d3b/attachment.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: setup.log.last3
Type: application/octet-stream
Size: 5244 bytes
Desc: setup.log.last3
URL: <http://cygwin.com/pipermail/cygwin/attachments/20101210/edab5d3b/attachment-0001.obj>
-------------- next part --------------
--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple


More information about the Cygwin mailing list