rebase, perl

Reini Urban rurban@x-ray.at
Fri Dec 17 19:42:00 GMT 2010


>> Yes. Adding a -d0 solved so far the problems on Win7 for me.
>>
>> diff -u /usr/bin/perlrebase~ /usr/bin/perlrebase
>> --- /usr/bin/perlrebase~        2010-11-27 10:13:07.806866000 +0100
>> +++ /usr/bin/perlrebase 2010-12-01 07:50:13.843953700 +0100
>> @@ -39,5 +39,5 @@
>>
>> /usr/bin/rebase -v -b $baseaddr -T rebase$suff.lst
>>
>> -[ -e /usr/bin/peflags.exe ]&&  /usr/bin/grep .dll rebase$suff.lst |
>> /usr/bin/peflags -d -T ->/dev/null
>> +[ -e /usr/bin/peflags.exe ]&&  /usr/bin/grep .dll rebase$suff.lst |
>> /usr/bin/peflags -d0 -T ->/dev/null
>> /usr/bin/cat rebase$suff.lst | /usr/bin/xargs chmod g-w
>
> Reini, this diff implies that the version of perlrebase I have is out of date since it doesn't use peflags anywhere.  I also found an old post from back in July where you stated that its "baseaddr=0x5400000" is missing a 0, suggesting it is at least that old.
> http://cygwin.com/ml/cygwin/2010-07/msg00146.html
>
> Where do I get an updated perlrebase?  I've tried performing updates from the latest released cygwin installer (no snapshots), but I still have what appears to be an outdated version.

perlrebase is in perl.
latest is perl-5.10.1-4

> Perhaps this is part of my current cpan/rebase hell....

Looks like so.

Attached is my latest and greatest version,
you don't need to install the complete perl, as not much changed there.

Now I'm trying starting from 56000000 as base, this seems to a bit 
better on win7 with lots of apps open.
-- 
Reini Urban
http://phpwiki.org/  http://murbreak.at/
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: perlrebase
URL: <http://cygwin.com/pipermail/cygwin/attachments/20101217/21202a56/attachment.ksh>
-------------- next part --------------
--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple


More information about the Cygwin mailing list