Syntax highlighting not working in vim73

Harrington, John
Mon Nov 8 22:46:00 GMT 2010

I recently upgraded vim in cygwin from vim63 to vim73.  I am running cygwin (with vim) on a Windows XP (version 5.1, sp3) machine.  

My problem is that syntax highlighting, which has worked fine for me in every previous version of vim suddenly doesn't not work.  I have not modified my vimrc files, so I'm at a loss to know what has changed.  

I have looked at the vim documentation and some online tutorials.  I seem to be doing everything I need to do to get syntax coloring to work.  I have turned on syntax in the /usr/share/vim/vimrc and in my .vimrc file in my home directory.  I have tried explicitly typing :syntax on in vim.  I have tried replacing my vimrc files with sample vimrc files that are supposed to work.  I have tried explicitly indicating syntax with the :set syn=<syntax-type> command.   Nothing seems to make a difference.  

Looking in /usr/share/vim/vim73/syntax, I see all of the syntax files there, including the file types I'm testing (such as python.vim, etc.).  

The cygwin window can represent colors just fine.  For example, ls --color works, but nothing I do seems to turn syntax coloring on.

There is nothing extraordinary about my installation of cygwin or vim or the configuration of my machine, so I'm guessing this is a problem many cygwin/vim users have had, but perhaps there's something that makes me unique.  Or maybe I'm doing something wrong, I just don't know.  

What should I try next?  Thanks.  

Best regards,

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list