sshd problem with recent snapshots

Ken Brown
Tue Nov 16 14:33:00 GMT 2010

On 11/16/2010 8:58 AM, Corinna Vinschen wrote:
> On Nov 15 15:25, Ken Brown wrote:
>> On 11/15/2010 11:53 AM, Corinna Vinschen wrote:
>>> On Nov 15 11:40, Christopher Faylor wrote:
>>>> On Mon, Nov 15, 2010 at 11:18:57AM -0500, Ken Brown wrote:
>>>>> On 11/15/2010 11:09 AM, Corinna Vinschen wrote:
>>>>>> On Nov 13 10:00, Ken Brown wrote:
>>>>>>> On 11/5/2010 8:03 AM, Ken Brown wrote:
>>>>>>>> $ ssh kbrown-admin@localhost
>>>>>>>> kbrown-admin@localhost's password:
>>>>>>>> Connection to localhost closed by remote host.
>>>>>>>> Connection to localhost closed.
>>>>>>>> The same thing happens if I try to ssh in from a different machine on
>>>>>>>> the network.
>>>>>>> [...]
>>>>>>> sshd: PID 2264: Accepted password for kbrown-admin from ::1 port 1025 ssh2.
>>>>>>> sshd: PID 2264: fatal: chmod(/dev/tty1, 0622) failed: Permission denied.
>>>>>> Hmm, that's weird.  I'm using the latest Cygwin from CVS, and I cannot
>>>>>> reproduce this.  I tried to login from a remote machine with pubkey and
>>>>>> password authentication using an admin account as well as a normal user
>>>>>> account.  Works fine for me in all these cases.
>>>>>> [...]
>>>>>>   What OS are you using?
>>>>> XP SP3.
>>>> FWIW, I couldn't duplicate this on XP SP3 but my ssh installation was a
>>>> little nonstandard.  [...]
>>> What I don't grok is that this should start with the 20100917 snapshot,
>>> but works with 20100912.  There's nothing in the 09-17 ChangeLog which
>>> would be related.
>> It doesn't make sense to me either, but I've just rechecked that the
>> problem occurs with the 09-17 snapshot (as well as the current one),
>> but not with the 09-12 snapshot.  I'm attaching my cygcheck output
>> (with the 09-17 snapshot installed) in case there's something there
>> that could be relevant.
> I tried with the 09-17 snapshot as well now, on XP SP3 with all the latest
> patches and on W7.  To no avail.  I still can login fine.  It does not
> matter if I try from a local login or from a remote machine, and it does
> not matter if I try to logon from a non-privileged account to a privileged
> account or vice versa.
>> Cygwin Configuration Diagnostics
>> Current System Time: Mon Nov 15 15:08:52 2010
> I don't see anything in your cygcheck output which would point to a
> problem.  There's just the fact that you apparently have (or had)
> another Cygwin installed in C:\cygwin:
>> Cygwin installations found in the registry:
>>    System: Key: 34ecc2f3970cc4c9 Path: D:\cygwin-1.7
>>    System: Key: c5e39b7a9d22bafb Path: C:\cygwin
> Is there a chance that your service entires still point to a cygrunsrv
> under C:\cygwin instead of D:\cygwin-1.7?

No.  The installation in C:\cygwin is newer than the one in D:\cygwin-1.7; it's just a small installation that I sometimes use for testing purposes, and it doesn't even have cygrunsrv installed.  In any case, that wouldn't explain why reverting to the 09-12 snapshot fixes the problem.  Are you sure there's nothing in the 09-17 Changelog that could account for this?  There do seem to be some network-related changes, though I don't claim to understand them:

	* (symlink_info::check_reparse_point): Add comment.
	(symlink_info::check): Fetch FileNetworkOpenInformation rather than
	FileBasicInformation throughout, except on NFS.  Explain why.  Store
	FILE_ATTRIBUTE_DIRECTORY attribute in conv_hdl for reparse point
	* path.h (class path_conv_handle): Add FILE_NETWORK_OPEN_INFORMATION
	member _fnoi.
	(path_conv_handle::fnoi): New accessor method for _fnoi.
	(path_conv::fnoi): New accessor method for cubv_hdl._fnoi.


Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list