Win 7 sshd help

Kirby Bakken
Fri Nov 19 21:17:00 GMT 2010


I recently installed cygwin w/sshd packages on my Win7 pro PC.  I've 
gotten ssh to work both with localhost, and with the LAN IP address.

However, trying to ssh from 'outside' my router doesn't work.  I CAN ssh 
to my linux box.  Then I change the port-forward in the router to my 
Win7 box, and I got 'permission denied' after the password prompt.  
After much fiddling, the /etc/host.allow/deny files have somewhere along 
the line disappeared.  Now, I get a timeout...


1) are the host.allow and deny files required?
2) are there any known problems with sshd running on Win7?

Before I 'munged' my installation and the allow/deny files diisappeared, 
I had tried su and login, and got permission denied errors....

I've un-installed sshd and re-installed it several times....

The /var/log/sshd.log file is oddly empty...  Trying to run 
/usr/sbin/sshd  and not as a service hasn't worked.

Ideas?  Suggestions?


Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list