Win 7 sshd help

Sat Nov 20 03:12:00 GMT 2010

On Fri, Nov 19, 2010 at 15:17, Kirby Bakken <> wrote:
> Help.
> I recently installed cygwin w/sshd packages on my Win7 pro PC.  I've gotten
> ssh to work both with localhost, and with the LAN IP address.
> However, trying to ssh from 'outside' my router doesn't work.  I CAN ssh to
> my linux box.  Then I change the port-forward in the router to my Win7 box,
> and I got 'permission denied' after the password prompt.  After much
> fiddling, the /etc/host.allow/deny files have somewhere along the line
> disappeared.  Now, I get a timeout...
> Questions:
> 1) are the host.allow and deny files required?

hosts.allow and hosts.deny only work if you compiled using tcp_wrappers

> 2) are there any known problems with sshd running on Win7?

I use SSHd on several Windows 7 machines (when I'm not on my native
OpenBSD laptop)

> Before I 'munged' my installation and the allow/deny files diisappeared, I
> had tried su and login, and got permission denied errors....
> I've un-installed sshd and re-installed it several times....
> The /var/log/sshd.log file is oddly empty...  Trying to run /usr/sbin/sshd
>  and not as a service hasn't worked.
> Ideas?  Suggestions?
> Kirby

Disable your windows 7 firewall, or make it so that it passes port 22.
 If you are remote, make sure your ISP isn't blocking port 22 inbound
to your router.  I had an ISP that blocked a lot of ports below 1024.

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list