scp just spews usage

Matthias Andree
Wed Nov 24 16:10:00 GMT 2010

Am 24.11.2010 15:26, schrieb Benjamin Anderson:
> Hi,
> I've been using ssh with cygwin for years w/ no issues.  After my last
> upgrade, I am not able to use scp (ssh still works).
> $ scp myfile myusername@myserver:~
> usage: scp [-1246BCpqrv] [-c cipher] [-F ssh_config] [-i identity_file]
>            [-l limit] [-o ssh_option] [-P port] [-S program]
>            [[user@]host1:]file1 ... [[user@]host2:]file2
> This same command has worked for me for long time.  Any ideas what's
> happening now?  (I have tried rebooting since the upgrade).

Does it work without trailing tilde (~)?  SCP/SSH will put you into the home
directory by default anyways, so it's not strictly required.

Are there blanks in any of the names? Then remember to quote the command
properly from the shell.

Is scp an alias?  Find out with "type alias" when using bash.

Matthias Andree

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list