R: libtermcap.a in cygwin 1.7.7.1

Thomas Wolff towo@towo.net
Fri Oct 1 11:05:00 GMT 2010


  Am 01.10.2010 11:56, schrieb Marco Atzeri:
> --- Ven 1/10/10, Dipak Gaigole  ha scritto:
>> Hello,
>>
>> Recently I had uninstalled my previous version of cygwin
>> (1.5.24) and
>> did a fresh install of latest cygwin (1.7.7.1)
>>
>> When I tried to recompile my code it failed because of
>> libtermcap.a
>> not found. This termcap library is needed by my code.
> newly compiled applications should use terminfo
> (that is, libncurses) and not libtermcap, see
> http://www.cygwin.com/ml/cygwin-announce/2009-12/msg00000.html
Actually, this is a linking issue. The old termcap API is emulated as 
part of the ncurses package,
so instead of -ltermcap just link with -lncurses. Source code can remain 
unchanged, also you can even continue to #include <termcap.h>; 
-I/usr/include/ncurses may have to be added to your compiler invocation.
Just in case you're running old programs, the old termcap database is 
also still available in package category "Utils".
------
Thomas

>> Further investigation shows that this library is missing
>> from this
>> latest cygwin installer package.
>>
>> As far as I know, the termcap library is provided under
>> "terminfo" or
>> the older "termcap" cygwin package.
>>
>> During my installation, I had included all the "devel"
>> packages.
>>
>> #########################################
>> Administrator@engwin03-64dev1 ~
>> $ cygcheck -c "cygwin"
>> Cygwin Package Information
>> Package Version Status
>> cygwin 1.7.7-1 OK
>>
>> Administrator@engwin03-64dev1 ~
>> $ cygcheck -c | egrep "ncurses|terminfo|termcap"
>> libncurses-devel 5.7-18 OK
>> libncurses10 5.7-18 OK
>> libncurses8 5.5-10 OK
>> libncurses9 5.7-16 OK
>> libncursesw-devel 5.7-18 OK
>> libncursesw10 5.7-18 OK
>> ncurses 5.7-18 OK
>> ncurses-demo 5.7-18 OK
>> ncursesw 5.7-18 OK
>> ncursesw-demo 5.7-18 OK
>> termcap 5.7_20091114-14 OK
>> terminfo 5.7_20091114-14 OK
>> terminfo0 5.5_20061104-12 OK
>>
>> Administrator@engwin03-64dev1 ~
>> $
>> #########################################
>>
>> Does anyone has faced similar issue?
>>
>> Meanwhile I am downloading the latest cygwin 1.7.7.1 source
>> code and
>> planning to recompile it.
>>
>> Thanks,
>> Dipak
>>
> Regards
> Marco
>
>
>
>
>
>
> --
> Problem reports:       http://cygwin.com/problems.html
> FAQ:                   http://cygwin.com/faq/
> Documentation:         http://cygwin.com/docs.html
> Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
>


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list