Possible Windows 7 issue? cc1.exe: error while loading shared libraries: ?

Taggart Ashby unknownsoldier1445@gmail.com
Mon Oct 4 17:36:00 GMT 2010


Hello,
I am wondering if anyone has encountered or might now how to fix the
following issue:

/usr/lib/gcc/i686-pc-cygwin/3.4.4/cc1.exe: error while loading shared libraries:
 ?: cannot open shared object file: No such file or directory

I have been using cygwin with ease for a couple years now, but
recently things aren't quite working out.

This issue started when I upgraded my operating system to Windows 7 64-bit.

Anytime I attempt to compile a C or C++ program (cc1plus.exe in that
case), I get the above error. I only get the error if I attempt to
compile from the windows command prompt.
If I run gcc in the Cygwin shell I have no problems.

I have tried reinstalling cygwin a few times to no avail.

I just got a new laptop yesterday, same operating system, and I am
getting the same problem again. Just another reason I feel like it's
an operating system issue.
Sorry if I have left out some crucial piece of information.
~Tag Ashby
-------------- next part --------------
A non-text attachment was scrubbed...
Name: cygcheck.out
Type: application/octet-stream
Size: 24194 bytes
Desc: not available
URL: <http://cygwin.com/pipermail/cygwin/attachments/20101004/e21aeb8c/attachment.obj>
-------------- next part --------------
--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple


More information about the Cygwin mailing list