emacs-23.2-3 and DBus

Ken Brown kbrown@cornell.edu
Wed Oct 6 18:48:00 GMT 2010

On 10/6/2010 2:12 PM, Ken Brown wrote:
> On 10/6/2010 1:51 PM, Michael Albinus wrote:
>> Ken Brown writes:
>>>> The binary has the following checksum:
>>>> $ cksum /usr/bin/emacs
>>>> 658187514 16254990 /usr/bin/emacs
>>> That's not actually the binary; it's a symlink that resolves to either
>>> /usr/bin/emacs-X11.exe or /usr/bin/emacs-nox.exe, depending on whether
>>> or not you've installed the emacs-X11 package.  Is it possible that
>>> you upgraded the emacs package but are still using an old emacs-X11?
>>> If not, I don't know what the problem could be.  If you can't figure
>>> it out, you could try giving the command
>>>     cygcheck -svr>   cygcheck.out
>>> and sending the resulting cygcheck.out as an attachment.  Maybe I (or
>>> someone) will be able to spot something.
>> I haven't the cygwin notebook with me, next access for me is tomorrow.
>> I'll check then.
>> The only difference I could imagine is that I haven't started the system
>> bus; only the session bus was running. Could you, please, check with
>> your environment? Maybe there is still a problem.
> Yes, that's it.  Emacs does freeze if I load dbus.el and the system bus
> isn't running.  But the problem doesn't occur in a build of Emacs from
> the trunk.  I vaguely recall that someone reported this problem last
> summer, and you fixed it.  But maybe you only fixed it in the trunk, and
> not in the emacs-23 branch.  Do I remember that correctly?

Here's what I was thinking of:



Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list