R: scp fails without a warning.

Marco Atzeri marco_atzeri@yahoo.it
Wed Oct 13 15:56:00 GMT 2010

--- Mer 13/10/10, Wiles, Dale L. (NE)  ha scritto:

> I updated cygwin yesterday (10/12/10)
> and rebooted my Windows XP (SP3) box.  Now, when I use
> scp from a Red Hat 5.5 box to my Windows box, scp quietly
> fails.

if you can not obtain at least
$ scp --version
scp: unknown option -- -
usage: scp [-1246BCpqrv] [-c cipher] [-F ssh_config] [-i identity_file]
           [-l limit] [-o ssh_option] [-P port] [-S program]
           [[user@]host1:]file1 ... [[user@]host2:]file2

then you lack one of the needed dll's
$ cygcheck scp
Found: C:\cygwin2\bin\scp.exe

to identify the missing one

> If I run (from Red Hat) "scp uname@windowsbox:file .", I'm
> prompted for my password.  I type it in and then, a
> moment later, scp exits.  No data gets transferred and
> there is no error messages.  If I type in a garbage
> file name, I get the same results.  There is no error
> message.
> If I run "sftp uname@windowsbox:file ." I'm prompted for my
> password and the file transfers normally. 
> Unfortunately I need a recursive copy.
> I can also ssh into my windows box with no problem.
> /var/log/sshd.log exists, but is empty.
> -- 
> Dale Wiles

Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list