R: LS_COLORS filetype color definitions are ignored

Marco Atzeri marco_atzeri@yahoo.it
Sun Oct 17 00:53:00 GMT 2010


--- Sab 16/10/10, Thayer Williams  ha scritto:

> Hi all,
> 
> I'm having trouble getting any of cygwin terminals to
> render LS_COLORS
> values for filetypes. Directories, links and executables
> are rendered
> in color, but individual files (zip archives, movies, etc.)
> are
> displayed all in one color. Found some years-old solutions
> on google,
> but none have worked.
> 
> Any suggestions?  Can someone confirm it works for
> them in any case?
> See below for specifics.
> 
> I'm using a freshly generated ~/.dircolors file
> 
> It's correctly evaluated and exported as :
> 
> $ echo $LS_COLORS
>
 rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.
xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=00;36:*.au=00;36:*.flac=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:*.axa=00;36:*.oga=00;36:*.spx=00;36:*.xspf=00;36:
> 
> TERM is correct (and it fails with the default cygwin bash
> shell too):
> 
> $ echo $TERM
> rxvt-cygwin
> 
> Neither 'ls --color=auto' nor 'ls --color=tty' render
> individual
> colors for filetypes, however the main three categories
> (dir,ln, and
> executable files) are colorized.
> 
> Any help would be most appreciated.
> 
> Cheers,
> 
> Thayer
> 

on my PC after
eval "`dircolors -b /etc/DIR_COLORS`"

all the zips come red

Regards
Marco




--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list