Bash problems, strace, performance, etc.

Lee D. Rothstein l1ee057@veritech.com
Tue Oct 19 22:56:00 GMT 2010


  On 10/19/2010 5:46 PM, Lee D. Rothstein wrote:
>  I'm confused. Something is wrong with my Cygwin configuration
> that has slowed Cygwin operation down drastically. The
> performance issue follows several problems with 'bash' that
> occurred while running nested scripts. The residual effect is
> slow performance. I've tried 'rebaseall', and that too failed
> (although frankly, I've never understood when that's called for
> or what it fixes, except in the most abstract of senses.). (See
> attached 'Rebaseall_Out.txt.)
>
> The "Bash problem" generates a complaint and a stack trace. The
> complaint is:
>
> C:\_0\bin\bash.exe: *** fatal error - WFSO timed out after longjmp
>
> The stack traces are listed in the attached file --
> Bash_Problem_Output.txt
>
> The highest level script that generated the problem was
> 'mkperlmanpdfs' (attached). 'mkperlmanpdfs', in turn, invokes
> 'man2pdf' (attached) repeatedly.
>
> During several of the 'man2pdf' invocations, errors
> are reported by 'man'/'groff' in rendering the 'man' "page" to
> Postscript. I've learned to live with these, and only rarely do
> they actually lead to omissions in the eventual PDF file. No big
> deal. In at least two of the cases, however, Bash itself seems to
> be reporting an error.
>
> I've tried shutting down all Cygwin/'mintty' windows, and killing
> all residual Cygwin processes/apps, using Task Manager. No help,
> whatsoever. I tried rebooting. That did help.
>
> I've also attached Cygcheck output. (The 'cygcheck' follows the
> reboot.)
>
> Attachments:
>
> -    Bash_Problem_Output.txt
> -    mkperlmanpdfs
> -    man2pdf
> -    Rebaseall_Out.txt
> -    cygcheck-hvscr+2010-10-19+17-35-48.txt

The two 'man2pdf' runs that cause the Bash crashes/straces are
'cpan.1' and 'cpanp.1'. I have eye-balled each and neither
appears unusual. They are, as are the 163 others Perl man pages,
'pod2man' renderings. (All of these are from the Cygwin Perl
distribution.)

Also, following the reboot, performance seems to have picked up
to the usual slothfulness of a Cygwin configuration on a Vista
64-bit, ahem, OS. ;-)

Lee

Lee

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list