Sending signals to a subprocess

Andy Koppe andy.koppe@gmail.com
Sun Oct 24 08:45:00 GMT 2010


On 24 October 2010 03:51, Ken Brown wrote:
> On 10/20/2010 4:32 PM, Christopher Faylor wrote:
>> I think I'm seeing some pattern to the way Linux handles [tcgetpgrp] and I
>> should be able to make Cygwin work the same way.
>
> This seems to be fixed in the latest snapshot, as far as emacs is concerned.

Works for mintty too. Thanks very much!

>  I no longer see any difference between Cygwin and Linux there.  I also get
> the expected results when I run the test cases that Andy posted.  But when I
> run the original test case that you posted in
>
>  http://cygwin.com/ml/cygwin/2010-10/msg00395.html
>
> I'm getting strange behavior.  I ran it with no argument, getting
>
> 0 = tcgetpgrp(4)
> 0 = ioctl(fd, TIOCGPGRP, &pid), pid = 0
>
> but then the terminal seemed to hang, and I didn't get a new prompt.  I
> tried this both in mintty and xterm.

It worked for me a couple of times before I got the hang. Locking trouble?

Andy

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list