strange crashes on invocation

Heath Kehoe
Thu Sep 23 22:27:00 GMT 2010

  I have a build system that uses rake under cygwin, and every so often 
a build tool will crash on invocation:

       1 [main] bclanc 1576! C:\budcat\tools\bin\bclanc.exe: *** fatal 
error - could not load w, Win32 error 998
Stack trace:
Frame     Function  Args
00289F44  6102740B  (00289F44, 00000000, 00000000, 00000000)
0028A234  6102740B  (61179C20, 00008000, 00000000, 6117B997)
0028B264  61004B2B  (6117B084, 61163DD0, 00000000, 00000000)
0028B4C4  6100137A  (61053A9A, 00000168, 00000002, 00000002)

bclanc is a tool compiled under cygwin that uses a few win32 APIs 
(Semaphore, CriticalSection, CreateThread). Unfortunately, this crash 
doesn't happen very often (maybe once every few hundred invocations). 
The build system does parallel processing similar to "make -jN", so 
there may be several build tools and compilers (both cygwin and 
non-cygwin) running or being invoked at any given time.

I tried setting the CYGWIN env variable (export 
CYGWIN="error_start:C:\cygwin\bin\gdb.exe") but gdb does not come up 
when this crash happens, so I'm at a loss for how to gather more info.

I checked against the BLODA, and I uninstalled Symantec Endpoint 
Protection in case it was causing any problems, however I still get 
these crashes. I don't have anything else on the BLODA.

My OS is Win7 x64. Cygwin is built from CVS as of 2010-09-21 12:11 
(though I'm pretty sure I've seen this on 1.7.7 as well)


This email has been scanned by the MessageLabs Email Security System.
For more information please visit 
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: cygcheck.out
URL: <>
-------------- next part --------------
Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list